Rating@Mail.ru

Форум по операционной системе GNU/Linux и свободному программному обеспечению


Текущее время: 20 июл 2017, 21:36

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 18 ]  На страницу 1, 2  След.
Автор Сообщение
 Заголовок сообщения: Viber
Непрочитанное сообщениеДобавлено: 21 май 2015, 15:30 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
Пока я эти ссылки показал для того, чтобы выделить список тех месенджеров, которые мне (IMHO) интересно наблюдать:
WhatsApp, Telegram, Bleep, Hangouts, Viber.

Очень расхваливаемый месенжер (и не только) Viber.
За счёт возможностей VoIP, многими рассматривается как потенциальная замена Skype ... свободная от множества недостатков Skype (Skype - программа загадочная :-D).

Viber существует для множества платформ ... практически для всего, что можно придумать ;-)
Но как-раз под Linux он получил реализацию поздно (07-08.2013г.), практически позже всех других платформ: Вышел Viber для Linux.
Цитата:
Изначально Viber предназначался для использования только на мобильных устройствах, но несколько месяцев назад был выпущен клиент для OS X и Windows. Ранее в этом месяце Viber Media выпустили Viber для Linux в виде публичной бета-версии. Сейчас для загрузки доступные бинарные файлы (правда, только для 64-битной архитектуры).


Viber для Linux
Цитата:
Лучшее приложение для звонков и обмена сообщениями под Linux!

Но у них на сайте "лучшего приложения для звонков и обмена сообщениями под Linux" есть только реализации под 64-бит:
Код:
bash-4.2$ ls -l
итого 43196
-rw-rw-r-- 1 Olej Olej 44232372 май 21 13:06 viber.rpm

bash-4.2$ sudo yum localinstall viber.rpm
Проверка viber.rpm: viber-4.2.2.6-2.x86_64
Невозможно добавить пакет viber.rpm в список действий. Несовместимая архитектура: x86_64
Выполнять нечего


Мне пока проверить не на чем, нет 64-бит инсталляции под рукой ... только отдал :-(
P.S. Вот интересная история: Skype существует в природе только в 32-бит реализации, и весь Интернет полнится стенаниями "как установить в 64-бит?" и советами на этот счёт как это сделать.
А у этих деятелей - обратная история: реализация только под 64-бит.


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 15 апр 2016, 14:40 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
Очень расхваливаемый месенжер (и не только) Viber.
За счёт возможностей VoIP, многими рассматривается как потенциальная замена Skype ... свободная от множества недостатков Skype

Возвращаюсь к Viber
1. создаю акаунт с планшета Android ...
2. акаунт создаётся по № моб. телефона
3. на указанный № приходит код активации (6 числовых зн.)
4. доп. информацию созданного акаунта снхронизирую с FaceBook


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 15 апр 2016, 14:50 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
Viber для Linux
Цитата:
Лучшее приложение для звонков и обмена сообщениями под Linux!


Цитата:
Viber Debian
64 бит
Viber RPM
64 бит

Код:
olej@osboxes:~/Downloads$ ls -l viber*
-rw-rw-r-- 1 olej olej 98721050 апр.  15 12:45 viber.deb
olej@osboxes:~/Downloads$ uname -a
Linux osboxes 3.16.0-48-generic #64~14.04.1-Ubuntu SMP Thu Aug 20 23:03:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Код:
olej@osboxes:~/Downloads$ ls -l viber*
-rw-rw-r-- 1 olej olej 98721050 апр.  15 12:45 viber.deb
olej@osboxes:~/Downloads$ uname -a
Linux osboxes 3.16.0-48-generic #64~14.04.1-Ubuntu SMP Thu Aug 20 23:03:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
olej@osboxes:~/Downloads$ sudo dpkg --install viber.deb
[sudo] password for olej:
Selecting previously unselected package viber.
(Reading database ... 225220 files and directories currently installed.)
Preparing to unpack viber.deb ...
Unpacking viber (6.0.1.5) ...
Setting up viber (6.0.1.5) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...

После чего запуск Viber появляется даже в системном меню ... как полагается...
Вложение:
Screenshot1.png
Screenshot1.png [ 937.03 КБ | Просмотров: 2598 ]


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 15 апр 2016, 15:23 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
После чего запуск Viber появляется даже в системном меню ... как полагается...

Но заканчивается это пока так:
Вложение:
Screenshot-Ubuntu.png
Screenshot-Ubuntu.png [ 20.85 КБ | Просмотров: 2598 ]

А запуск в терминале подсказывает:
Код:
olej@osboxes:/opt/viber$ ./Viber
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, wayland-egl, wayland, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)

Это очень даже возможно из-за DE: Mate ... и это можно победить. ;-)


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 15 апр 2016, 20:34 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
Это очень даже возможно из-за DE: Mate ... и это можно победить. ;-)

Это победить то можно:
Код:
olej@osboxes:/opt/viber$ sudo apt-get install qtubuntu-desktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libandroid-properties1 libboost-program-options1.54.0 libdbus-cpp2
  libgflags2 libgoogle-glog0 libhybris-common1 libmirplatform
  libmirplatformgraphics-mesa libmirserver18 libprocess-cpp1 libqt5core5a
  libqt5dbus5 libqt5feedback5 libqt5gui5 libqt5multimedia5 libqt5network5
  libqt5positioning5 libqt5sensors5 libubuntu-application-api-mirclient1
  libubuntu-application-api-mirserver1 libubuntu-application-api1
  libubuntu-location-service0 libubuntu-platform-hardware-api1 libunwind8
  libxcb-icccm4 libxcb-image0 libxcb-render-util0 libxcb-xkb1
  libxkbcommon-x11-0 qtubuntu-sensors
The following NEW packages will be installed
  libandroid-properties1 libboost-program-options1.54.0 libdbus-cpp2
  libgflags2 libgoogle-glog0 libhybris-common1 libmirplatform
  libmirplatformgraphics-mesa libmirserver18 libprocess-cpp1 libqt5core5a
  libqt5dbus5 libqt5feedback5 libqt5gui5 libqt5multimedia5 libqt5network5
  libqt5positioning5 libqt5sensors5 libubuntu-application-api-mirclient1
  libubuntu-application-api-mirserver1 libubuntu-application-api1
  libubuntu-location-service0 libubuntu-platform-hardware-api1 libunwind8
  libxcb-icccm4 libxcb-image0 libxcb-render-util0 libxcb-xkb1
  libxkbcommon-x11-0 qtubuntu-desktop qtubuntu-sensors
0 to upgrade, 31 to newly install, 0 to remove and 452 not to upgrade.
Need to get 6 286 kB of archives.
After this operation, 25,1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ru.archive.ubuntu.com/ubuntu/ trusty-updates/main libboost-program-options1.54.0 amd64 1.54.0-4ubuntu3.1 [115 kB]
Get:2 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libgflags2 amd64 2.0-1.1ubuntu1 [65,9 kB]
Get:3 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libunwind8 amd64 1.1-2.2ubuntu3 [48,3 kB]
Get:4 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libgoogle-glog0 amd64 0.3.3-1 [61,3 kB]
Get:5 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libmirplatform amd64 0.1.8+14.04.20140411-0ubuntu1 [24,9 kB]
Get:6 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libmirplatformgraphics-mesa amd64 0.1.8+14.04.20140411-0ubuntu1 [115 kB]
Get:7 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libmirserver18 amd64 0.1.8+14.04.20140411-0ubuntu1 [515 kB]
Get:8 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libprocess-cpp1 amd64 1.0.0+14.04.20140328-0ubuntu1 [46,6 kB]
Get:9 http://ru.archive.ubuntu.com/ubuntu/ trusty-security/main libqt5core5a amd64 5.2.1+dfsg-1ubuntu14.3 [1 748 kB]
Get:10 http://ru.archive.ubuntu.com/ubuntu/ trusty-security/main libqt5dbus5 amd64 5.2.1+dfsg-1ubuntu14.3 [176 kB]
Get:11 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libxcb-icccm4 amd64 0.4.1-1ubuntu1 [10,4 kB]
Get:12 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libxcb-image0 amd64 0.3.9-1ubuntu2 [11,5 kB]
Get:13 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libxcb-render-util0 amd64 0.3.8-1.1ubuntu1 [8 702 B]
Get:14 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libxcb-xkb1 amd64 1.10-2ubuntu1 [28,4 kB]
Get:15 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libxkbcommon-x11-0 amd64 0.4.1-0ubuntu1 [13,6 kB]
Get:16 http://ru.archive.ubuntu.com/ubuntu/ trusty-security/main libqt5gui5 amd64 5.2.1+dfsg-1ubuntu14.3 [1 857 kB]
Get:17 http://ru.archive.ubuntu.com/ubuntu/ trusty-security/main libqt5network5 amd64 5.2.1+dfsg-1ubuntu14.3 [502 kB]
Get:18 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libqt5multimedia5 amd64 5.2.1-0ubuntu5 [226 kB]
Get:19 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libqt5feedback5 amd64 5.0~git20130529-0ubuntu3 [25,8 kB]
Get:20 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libqt5positioning5 amd64 5.2.1-1ubuntu2 [71,2 kB]
Get:21 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libqt5sensors5 amd64 5.2.1+dfsg-2ubuntu2 [104 kB]
Get:22 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libdbus-cpp2 amd64 2.0.0+14.04.20140326-0ubuntu1 [92,9 kB]
Get:23 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libandroid-properties1 amd64 0.1.0+git20131207+e452e83-0ubuntu12 [9 494 B]
Get:24 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libhybris-common1 amd64 0.1.0+git20131207+e452e83-0ubuntu12 [27,6 kB]
Get:25 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libubuntu-platform-hardware-api1 amd64 0.20+14.04.20140411-0ubuntu1 [7 032 B]
Get:26 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libubuntu-location-service0 amd64 0.0.2+14.04.20140307-0ubuntu1 [183 kB]
Get:27 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libubuntu-application-api-mirclient1 amd64 0.20+14.04.20140411-0ubuntu1 [35,3 kB]
Get:28 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libubuntu-application-api-mirserver1 amd64 0.20+14.04.20140411-0ubuntu1 [31,1 kB]
Get:29 http://ru.archive.ubuntu.com/ubuntu/ trusty/main libubuntu-application-api1 amd64 0.20+14.04.20140411-0ubuntu1 [25,3 kB]
Get:30 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe qtubuntu-sensors amd64 0.6+14.04.20140304-0ubuntu1 [21,8 kB]
Get:31 http://ru.archive.ubuntu.com/ubuntu/ trusty/universe qtubuntu-desktop amd64 0.54+14.04.20140402-0ubuntu2 [79,4 kB]
Fetched 6 286 kB in 7s (836 kB/s)                                             
Extract templates from packages: 100%
Selecting previously unselected package libboost-program-options1.54.0:amd64.
(Reading database ... 225960 files and directories currently installed.)
Preparing to unpack .../libboost-program-options1.54.0_1.54.0-4ubuntu3.1_amd64.deb ...
Unpacking libboost-program-options1.54.0:amd64 (1.54.0-4ubuntu3.1) ...
Selecting previously unselected package libgflags2.
Preparing to unpack .../libgflags2_2.0-1.1ubuntu1_amd64.deb ...
Unpacking libgflags2 (2.0-1.1ubuntu1) ...
Selecting previously unselected package libunwind8.
Preparing to unpack .../libunwind8_1.1-2.2ubuntu3_amd64.deb ...
Unpacking libunwind8 (1.1-2.2ubuntu3) ...
Selecting previously unselected package libgoogle-glog0.
Preparing to unpack .../libgoogle-glog0_0.3.3-1_amd64.deb ...
Unpacking libgoogle-glog0 (0.3.3-1) ...
Selecting previously unselected package libmirplatform:amd64.
Preparing to unpack .../libmirplatform_0.1.8+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libmirplatform:amd64 (0.1.8+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package libmirplatformgraphics-mesa:amd64.
Preparing to unpack .../libmirplatformgraphics-mesa_0.1.8+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libmirplatformgraphics-mesa:amd64 (0.1.8+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package libmirserver18:amd64.
Preparing to unpack .../libmirserver18_0.1.8+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libmirserver18:amd64 (0.1.8+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package libprocess-cpp1:amd64.
Preparing to unpack .../libprocess-cpp1_1.0.0+14.04.20140328-0ubuntu1_amd64.deb ...
Unpacking libprocess-cpp1:amd64 (1.0.0+14.04.20140328-0ubuntu1) ...
Selecting previously unselected package libqt5core5a:amd64.
Preparing to unpack .../libqt5core5a_5.2.1+dfsg-1ubuntu14.3_amd64.deb ...
Unpacking libqt5core5a:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Selecting previously unselected package libqt5dbus5:amd64.
Preparing to unpack .../libqt5dbus5_5.2.1+dfsg-1ubuntu14.3_amd64.deb ...
Unpacking libqt5dbus5:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Selecting previously unselected package libxcb-icccm4:amd64.
Preparing to unpack .../libxcb-icccm4_0.4.1-1ubuntu1_amd64.deb ...
Unpacking libxcb-icccm4:amd64 (0.4.1-1ubuntu1) ...
Selecting previously unselected package libxcb-image0:amd64.
Preparing to unpack .../libxcb-image0_0.3.9-1ubuntu2_amd64.deb ...
Unpacking libxcb-image0:amd64 (0.3.9-1ubuntu2) ...
Selecting previously unselected package libxcb-render-util0:amd64.
Preparing to unpack .../libxcb-render-util0_0.3.8-1.1ubuntu1_amd64.deb ...
Unpacking libxcb-render-util0:amd64 (0.3.8-1.1ubuntu1) ...
Selecting previously unselected package libxcb-xkb1:amd64.
Preparing to unpack .../libxcb-xkb1_1.10-2ubuntu1_amd64.deb ...
Unpacking libxcb-xkb1:amd64 (1.10-2ubuntu1) ...
Selecting previously unselected package libxkbcommon-x11-0:amd64.
Preparing to unpack .../libxkbcommon-x11-0_0.4.1-0ubuntu1_amd64.deb ...
Unpacking libxkbcommon-x11-0:amd64 (0.4.1-0ubuntu1) ...
Selecting previously unselected package libqt5gui5:amd64.
Preparing to unpack .../libqt5gui5_5.2.1+dfsg-1ubuntu14.3_amd64.deb ...
Unpacking libqt5gui5:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Selecting previously unselected package libqt5network5:amd64.
Preparing to unpack .../libqt5network5_5.2.1+dfsg-1ubuntu14.3_amd64.deb ...
Unpacking libqt5network5:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Selecting previously unselected package libqt5multimedia5:amd64.
Preparing to unpack .../libqt5multimedia5_5.2.1-0ubuntu5_amd64.deb ...
Unpacking libqt5multimedia5:amd64 (5.2.1-0ubuntu5) ...
Selecting previously unselected package libqt5feedback5:amd64.
Preparing to unpack .../libqt5feedback5_5.0~git20130529-0ubuntu3_amd64.deb ...
Unpacking libqt5feedback5:amd64 (5.0~git20130529-0ubuntu3) ...
Selecting previously unselected package libqt5positioning5:amd64.
Preparing to unpack .../libqt5positioning5_5.2.1-1ubuntu2_amd64.deb ...
Unpacking libqt5positioning5:amd64 (5.2.1-1ubuntu2) ...
Selecting previously unselected package libqt5sensors5:amd64.
Preparing to unpack .../libqt5sensors5_5.2.1+dfsg-2ubuntu2_amd64.deb ...
Unpacking libqt5sensors5:amd64 (5.2.1+dfsg-2ubuntu2) ...
Selecting previously unselected package libdbus-cpp2:amd64.
Preparing to unpack .../libdbus-cpp2_2.0.0+14.04.20140326-0ubuntu1_amd64.deb ...
Unpacking libdbus-cpp2:amd64 (2.0.0+14.04.20140326-0ubuntu1) ...
Selecting previously unselected package libandroid-properties1.
Preparing to unpack .../libandroid-properties1_0.1.0+git20131207+e452e83-0ubuntu12_amd64.deb ...
Unpacking libandroid-properties1 (0.1.0+git20131207+e452e83-0ubuntu12) ...
Selecting previously unselected package libhybris-common1.
Preparing to unpack .../libhybris-common1_0.1.0+git20131207+e452e83-0ubuntu12_amd64.deb ...
Unpacking libhybris-common1 (0.1.0+git20131207+e452e83-0ubuntu12) ...
Selecting previously unselected package libubuntu-platform-hardware-api1:amd64.
Preparing to unpack .../libubuntu-platform-hardware-api1_0.20+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libubuntu-platform-hardware-api1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package libubuntu-location-service0:amd64.
Preparing to unpack .../libubuntu-location-service0_0.0.2+14.04.20140307-0ubuntu1_amd64.deb ...
Unpacking libubuntu-location-service0:amd64 (0.0.2+14.04.20140307-0ubuntu1) ...
Selecting previously unselected package libubuntu-application-api-mirclient1:amd64.
Preparing to unpack .../libubuntu-application-api-mirclient1_0.20+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libubuntu-application-api-mirclient1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package libubuntu-application-api-mirserver1:amd64.
Preparing to unpack .../libubuntu-application-api-mirserver1_0.20+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libubuntu-application-api-mirserver1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package libubuntu-application-api1:amd64.
Preparing to unpack .../libubuntu-application-api1_0.20+14.04.20140411-0ubuntu1_amd64.deb ...
Unpacking libubuntu-application-api1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Selecting previously unselected package qtubuntu-sensors:amd64.
Preparing to unpack .../qtubuntu-sensors_0.6+14.04.20140304-0ubuntu1_amd64.deb ...
Unpacking qtubuntu-sensors:amd64 (0.6+14.04.20140304-0ubuntu1) ...
Selecting previously unselected package qtubuntu-desktop:amd64.
Preparing to unpack .../qtubuntu-desktop_0.54+14.04.20140402-0ubuntu2_amd64.deb ...
Unpacking qtubuntu-desktop:amd64 (0.54+14.04.20140402-0ubuntu2) ...
Setting up libboost-program-options1.54.0:amd64 (1.54.0-4ubuntu3.1) ...
Setting up libgflags2 (2.0-1.1ubuntu1) ...
Setting up libunwind8 (1.1-2.2ubuntu3) ...
Setting up libgoogle-glog0 (0.3.3-1) ...
Setting up libmirplatform:amd64 (0.1.8+14.04.20140411-0ubuntu1) ...
Setting up libmirplatformgraphics-mesa:amd64 (0.1.8+14.04.20140411-0ubuntu1) ...
update-alternatives: using /usr/lib/x86_64-linux-gnu/mir/platformgraphics/mesa/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_mirplatformgraphics.conf (x86_64-linux-gnu_mirplatformgraphics_conf) in auto mode
Setting up libmirserver18:amd64 (0.1.8+14.04.20140411-0ubuntu1) ...
Setting up libprocess-cpp1:amd64 (1.0.0+14.04.20140328-0ubuntu1) ...
Setting up libqt5core5a:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Setting up libqt5dbus5:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Setting up libxcb-icccm4:amd64 (0.4.1-1ubuntu1) ...
Setting up libxcb-image0:amd64 (0.3.9-1ubuntu2) ...
Setting up libxcb-render-util0:amd64 (0.3.8-1.1ubuntu1) ...
Setting up libxcb-xkb1:amd64 (1.10-2ubuntu1) ...
Setting up libxkbcommon-x11-0:amd64 (0.4.1-0ubuntu1) ...
Setting up libqt5gui5:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Setting up libqt5network5:amd64 (5.2.1+dfsg-1ubuntu14.3) ...
Setting up libqt5multimedia5:amd64 (5.2.1-0ubuntu5) ...
Setting up libqt5feedback5:amd64 (5.0~git20130529-0ubuntu3) ...
Setting up libqt5positioning5:amd64 (5.2.1-1ubuntu2) ...
Setting up libqt5sensors5:amd64 (5.2.1+dfsg-2ubuntu2) ...
Setting up libdbus-cpp2:amd64 (2.0.0+14.04.20140326-0ubuntu1) ...
Setting up libandroid-properties1 (0.1.0+git20131207+e452e83-0ubuntu12) ...
Setting up libhybris-common1 (0.1.0+git20131207+e452e83-0ubuntu12) ...
Setting up libubuntu-platform-hardware-api1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Setting up libubuntu-location-service0:amd64 (0.0.2+14.04.20140307-0ubuntu1) ...
Setting up libubuntu-application-api-mirclient1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Setting up libubuntu-application-api-mirserver1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Setting up libubuntu-application-api1:amd64 (0.20+14.04.20140411-0ubuntu1) ...
Setting up qtubuntu-sensors:amd64 (0.6+14.04.20140304-0ubuntu1) ...
Setting up qtubuntu-desktop:amd64 (0.54+14.04.20140402-0ubuntu2) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

Но тут возникает совершенно другая напасть с OpenGL:
Код:
olej@osboxes:/opt/viber$ ./Viber
libGL error: pci id for fd 12: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
OpenGL Warning: glXGetFBConfigAttrib for 000000000564ba90, failed to get XVisualInfo
OpenGL Warning: XGetVisualInfo returned 0 visuals for 000000000564ba90
OpenGL Warning: Retry with 0x8002 returned 0 visuals
Could not initialize GLX
Aborted (core dumped)

Это связано, скорее всего, с тем, что я это запускаю в 64-бит виртуальной машине VrtualBox, и проблемы с её драйвером vboxvideo.


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 16 апр 2016, 01:12 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
Это связано, скорее всего, с тем, что я это запускаю в 64-бит виртуальной машине VrtualBox, и проблемы с её драйвером vboxvideo.

Проверяем:
1. что установлено расширение гостевой ОС:
Код:
olej@osboxes:/media/olej/VBOXADDITIONS_5.0.16_105871$ sudo ./VBoxLinuxAdditions.run.
Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.16 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.2 of VirtualBox Guest Additions...
Stopping VirtualBox Additions ...fail!
(Cannot unload module vboxguest)
Removing existing VirtualBox non-DKMS kernel modules ...done.
Stopping VirtualBox Guest Addition service  ...done.
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...done.
Building the shared folder support module ...done.
Building the OpenGL support module ...done.
Doing non-kernel setup of the Guest Additions ...done.
You should restart your guest to make sure the new modules are actually used

Installing the Window System drivers
Installing X.Org Server 1.15 modules ...done.
Setting up the Window System to use the Guest Additions ...done.
You may need to restart the the Window System (or just restart the guest system)
to enable the Guest Additions.

Installing graphics libraries and desktop services components ...done.

2. Что Open GL нормально работает при установленном 3D-ускорении в свойствах VM (картинка GLOBS - бэнчмарк для GL).
Вложение:
Screenshot-GL O.B.S..png
Screenshot-GL O.B.S..png [ 47.5 КБ | Просмотров: 2590 ]


Так что проблема здесь, похоже, в Viber ... или, возможно, в недоустановленных по зависимостям что-то из библиотек GL.


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 16 апр 2016, 15:27 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Olej писал(а):
Так что проблема здесь, похоже, в Viber ... или, возможно, в недоустановленных по зависимостям что-то из библиотек GL.

Как оказалось:
1. это хорошо и давно известная проблема с OpenGL VirtualBox, вот Ticket #12941 (new defect), открытый более 2-х лет назад и разрешившийся (возможно?) только 9 дней назад...
2. вот что пишут об этом на странице https://www.virtualbox.org/wiki/Downloads VirtualBox:
Цитата:
Guest Additions update for Linux guests

After the 5.0.16 release, the Guest Additions were updated to support Linux guests with X.Org Server running without root privileges and to fix certain 3D acceleration-related issues.

VirtualBox 5.0.17 Guest Additions installer image
See here for the latest 5.0.x Additions test build containing the code


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 16 апр 2016, 17:24 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Установил VirtualBox 5.0.17 Guest Additions (см. VirtualBox (ресурсы и возможности))
OpenGL наладился.
Но запуску Viber это всё-рано не помогает:
Код:
olej@osboxes:/opt/viber$ ./Viber
OpenGL Warning: glXCreatePbuffer not implemented by Chromium
OpenGL Warning: glXCreatePbuffer not implemented by Chromium
QOpenGLFramebufferObject: Unsupported framebuffer format.
QObject::connect: Cannot connect (null)::stateChanged(QNetworkSession::State) to QNetworkReplyHttpImpl::_q_networkSessionStateChanged(QNetworkSession::State)
Segmentation fault (core dumped)

Код:
olej@osboxes:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   Humper
OpenGL renderer string: Chromium
OpenGL version string:  2.1 Chromium 1.9

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 30 июн 2016, 00:00 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Напомнили мне, что я не доустановил Viber под Linux до конца...
Теперь это:
Код:
[olej@dell 2016_WORK]$ lsb_release -ircd
Distributor ID:   Fedora
Description:   Fedora release 23 (Twenty Three)
Release:   23
Codename:   TwentyThree

Берём здесь - Viber для Linux
Код:
[olej@dell Messanger]$ ls -l viber.rpm
-rw-rw-r--. 1 olej olej 138348910 июн 29 23:26 viber.rpm

Код:
[olej@dell Messanger]$ sudo dnf install viber.rpm
...
Выполнение транзакции
  Установка    : viber-6.0.1.5-2.x86_64                                                                                                  1/1
  Проверка     : viber-6.0.1.5-2.x86_64                                                                                                  1/1
Установлено:
  viber.x86_64 6.0.1.5-2
Выполнено!

Код:
[olej@dell Messanger]$ which Viber
/usr/bin/which: no Viber in (/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/opt/android-studio/bin:/home/olej/.local/bin:/home/olej/bin:/opt/android-studio/bin:/opt/android-studio/bin)

На путях его нет, но появился значок в меню запуска, и в его свойствах находим: /opt/viber/Viber
Код:
[olej@dell Messanger]$ ls -l /opt/viber
итого 178000
drwxr-xr-x. 1 root root       170 июн 29 23:33 icons
-rw-r--r--. 1 root root  10456832 апр 13 15:41 icudtl.dat
drwxr-xr-x. 1 root root       980 июн 29 23:33 lib
-rwxr-xr-x. 1 root root   6443456 апр 13 15:41 linkParser
drwxr-xr-x. 1 root root       254 июн 29 23:33 plugins
drwxr-xr-x. 1 root root       194 июн 29 23:33 qml
-rw-r--r--. 1 root root        61 апр 13 15:41 qt.conf
-rwxr-xr-x. 1 root root      6472 апр 13 15:41 QtWebEngineProcess
-rw-r--r--. 1 root root    741566 апр 13 15:41 qtwebengine_resources_100p.pak
-rw-r--r--. 1 root root    848323 апр 13 15:41 qtwebengine_resources_200p.pak
-rw-r--r--. 1 root root   5656131 апр 13 15:41 qtwebengine_resources.pak
drwxr-xr-x. 1 root root       404 июн 29 23:33 Sound
-rw-r--r--. 1 root root    628314 апр 13 15:41 SplashScreen.rcc
drwxr-xr-x. 1 root root      5944 июн 29 23:33 translations
-rwxr-xr-x. 1 root root 157467682 апр 13 15:41 Viber


Вернуться к началу
 Профиль Отправить личное сообщение  
 
 Заголовок сообщения: Re: Месенжеры
Непрочитанное сообщениеДобавлено: 30 июн 2016, 00:10 
Не в сети
Писатель
Аватара пользователя

Зарегистрирован: 24 сен 2011, 14:22
Сообщения: 9770
Откуда: Харьков
Вложение:
v1.png
v1.png [ 92.6 КБ | Просмотров: 2764 ]


Вложение:
v2.png
v2.png [ 95.21 КБ | Просмотров: 2764 ]

Я ввожу тел. номер Viber аккаунта, ранее созданного с планшета с Android.
А вот в этом месте возникает новое непредвиденное затруднение:
- на экран выскакивает QR-код для подтверждения безопасности
- его нужно сосчитать камерой планшеты чтобы пройти...
- без планшета под рукой, думаю, пройти этот шаг невозможно.
Вложение:
v3.png
v3.png [ 63.15 КБ | Просмотров: 2764 ]


Вложение:
v4.png
v4.png [ 134.2 КБ | Просмотров: 2764 ]


Вернуться к началу
 Профиль Отправить личное сообщение  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 18 ]  На страницу 1, 2  След.

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
[ Time : 0.220s | 21 Queries | GZIP : On ]